$re = '/^(?:\d{1,3}[A-I])?$/m';
$str = '
123A
123b
123B
12Z
12A
A
10A
123B
33F
1A
1234A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);