#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<FileNameWithoutExtension>\w+)(\.\w+)?[^\/]*$"
Local $sString = "/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr" & @CRLF & _
"/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr.20150901170004.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")