import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<FileNameWithoutExtension>\\w+)(\\.\\w+)?[^\\/]*$";
final String string = "/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr\n"
+ "/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr.20150901170004.txt\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}