using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<FileNameWithoutExtension>\w+)(\.\w+)?[^\/]*$";
string input = @"/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr
/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr.20150901170004.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}