package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<FileNameWithoutExtension>\w+)(\.\w+)?[^\/]*$`)
var str = `/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr
/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr.20150901170004.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}