re = /(?<FileNameWithoutExtension>\w+)(\.\w+)?[^\/]*$/m
str = '/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr
/home/cmagnuson/Documents/WCSLogBackups/autoShipMgr.20150901170004.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end