import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,8}?(\\.)?(\\d{1,2})?$";
final String string = "\n"
+ "0\n"
+ "123\n"
+ "1234567890\n"
+ "12345678901\n"
+ "1234.\n"
+ "0.\n"
+ "1234567890.12\n"
+ "1234567890.123\n"
+ ".1\n"
+ ".12\n"
+ ".123\n"
+ ".\n"
+ "123.123\n"
+ "123.12\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}