re = /^\d{0,8}?(\.)?(\d{1,2})?$/m
str = '
0
123
1234567890
12345678901
1234.
0.
1234567890.12
1234567890.123
.1
.12
.123
.
123.123
123.12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end