const regex = /^\d{0,8}?(\.)?(\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,8}?(\\.)?(\\d{1,2})?$', 'gm')
const str = `
0
123
1234567890
12345678901
1234.
0.
1234567890.12
1234567890.123
.1
.12
.123
.
123.123
123.12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}