// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{0,8}?(\.)?(\d{1,2})?$").unwrap();
let string = "
0
123
1234567890
12345678901
1234.
0.
1234567890.12
1234567890.123
.1
.12
.123
.
123.123
123.12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}