import re
regex = re.compile(r"^\d{0,8}?(\.)?(\d{1,2})?$", flags=re.MULTILINE)
test_str = ("\n"
"0\n"
"123\n"
"1234567890\n"
"12345678901\n"
"1234.\n"
"0.\n"
"1234567890.12\n"
"1234567890.123\n"
".1\n"
".12\n"
".123\n"
".\n"
"123.123\n"
"123.12\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")