using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0(?!0)|[1-2]|3(?=[0-1]))\d\/(0(?!0)|1(?=[0-2]))\d\/\d{4}";
string input = @" some matched dates (DD/MM/YYYY): 33/18/2005 31/01/2009
basic check for month/day boundaries: 33/02/2005 12/18/2007
NO check for month specific boundary: 31/22/2009
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}