import re
regex = re.compile(r"(0(?!0)|[1-2]|3(?=[0-1]))\d\/(0(?!0)|1(?=[0-2]))\d\/\d{4}")
test_str = (" some matched dates (DD/MM/YYYY): 33/18/2005 31/01/2009\n\n"
"basic check for month/day boundaries: 33/02/2005 12/18/2007\n\n"
"NO check for month specific boundary: 31/22/2009\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")