const regex = /(0(?!0)|[1-2]|3(?=[0-1]))\d\/(0(?!0)|1(?=[0-2]))\d\/\d{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0(?!0)|[1-2]|3(?=[0-1]))\\d\\\/(0(?!0)|1(?=[0-2]))\\d\\\/\\d{4}', 'g')
const str = ` some matched dates (DD/MM/YYYY): 33/18/2005 31/01/2009
basic check for month/day boundaries: 33/02/2005 12/18/2007
NO check for month specific boundary: 31/22/2009
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}