import Foundation
let pattern = #"(0(?!0)|[1-2]|3(?=[0-1]))\d\/(0(?!0)|1(?=[0-2]))\d\/\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
some matched dates (DD/MM/YYYY): 33/18/2005 31/01/2009
basic check for month/day boundaries: 33/02/2005 12/18/2007
NO check for month specific boundary: 31/22/2009
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)