using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\-|\/|\.|[a-z]|.{1})\d+";
string input = @"19-21
2 G
A
1 bis
3 C
N°10
17 b
76 B
7 ter
9/11
21.3
42";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}