import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\-|\\/|\\.|[a-z]|.{1})\\d+";
final String string = "19-21\n"
+ "2 G\n"
+ "A\n"
+ "1 bis\n"
+ "3 C\n"
+ "N°10\n"
+ "17 b\n"
+ "76 B\n"
+ "7 ter\n"
+ "9/11\n"
+ "21.3\n"
+ "42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}