const regex = /(?<!\-|\/|\.|[a-z]|.{1})\d+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\-|\\\/|\\.|[a-z]|.{1})\\d+', 'gmi')
const str = `19-21
2 G
A
1 bis
3 C
N°10
17 b
76 B
7 ter
9/11
21.3
42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}