$re = '/(?<!\-|\/|\.|[a-z]|.{1})\d+/mi';
$str = '19-21
2 G
A
1 bis
3 C
N°10
17 b
76 B
7 ter
9/11
21.3
42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);