use strict;
my $str = '19-21
2 G
A
1 bis
3 C
N°10
17 b
76 B
7 ter
9/11
21.3
42';
my $regex = qr/(?<!\-|\/|\.|[a-z]|.{1})\d+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}