using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<bar>\|(?:{(?P<num>[0-9]+), *(?P<denom>[0-9]+)})?)? *(?P<chord>\[[^\]]+\])?(?P<lyric>.*)$";
string input = @"Hello
|Hello
|[Am]Hello
|{1,2}Hello
|{1,2}[Am]Hello
|{1,12}[Am G] Hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}