// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<bar>\|(?:{(?P<num>[0-9]+), *(?P<denom>[0-9]+)})?)? *(?P<chord>\[[^\]]+\])?(?P<lyric>.*)$").unwrap();
let string = "Hello
|Hello
|[Am]Hello
|{1,2}Hello
|{1,2}[Am]Hello
|{1,12}[Am G] Hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}