$re = '/^(?P<bar>\|(?:{(?P<num>[0-9]+), *(?P<denom>[0-9]+)})?)? *(?P<chord>\[[^\]]+\])?(?P<lyric>.*)$/m';
$str = 'Hello
|Hello
|[Am]Hello
|{1,2}Hello
|{1,2}[Am]Hello
|{1,12}[Am G] Hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);