re = /^(?P<bar>\|(?:{(?P<num>[0-9]+), *(?P<denom>[0-9]+)})?)? *(?P<chord>\[[^\]]+\])?(?P<lyric>.*)$/m
str = 'Hello
|Hello
|[Am]Hello
|{1,2}Hello
|{1,2}[Am]Hello
|{1,12}[Am G] Hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end