import re
regex = re.compile(r"^(?P<bar>\|(?:{(?P<num>[0-9]+), *(?P<denom>[0-9]+)})?)? *(?P<chord>\[[^\]]+\])?(?P<lyric>.*)$", flags=re.MULTILINE)
test_str = ("Hello\n"
"|Hello\n"
"|[Am]Hello\n"
"|{1,2}Hello\n"
"|{1,2}[Am]Hello\n"
"|{1,12}[Am G] Hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")