using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@)G.{16}R(?=@)";
string input = @"kjfoih6fn@PVIJF928G5@G8G8v8AGGtVGR8VRXR@VKJEOIHGQP5V4R4frg97etrg@53qvhF";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}