use strict;
my $str = 'kjfoih6fn@PVIJF928G5@G8G8v8AGGtVGR8VRXR@VKJEOIHGQP5V4R4frg97etrg@53qvhF';
my $regex = qr/(?<=@)G.{16}R(?=@)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}