import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@)G.{16}R(?=@)";
final String string = "kjfoih6fn@PVIJF928G5@G8G8v8AGGtVGR8VRXR@VKJEOIHGQP5V4R4frg97etrg@53qvhF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}