import Foundation
let pattern = #"(?<=@)G.{16}R(?=@)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"kjfoih6fn@PVIJF928G5@G8G8v8AGGtVGR8VRXR@VKJEOIHGQP5V4R4frg97etrg@53qvhF"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)