const regex = /(?<=@)G.{16}R(?=@)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@)G.{16}R(?=@)', 'g')
const str = `kjfoih6fn@PVIJF928G5@G8G8v8AGGtVGR8VRXR@VKJEOIHGQP5V4R4frg97etrg@53qvhF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}