package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d\d{0,1}){1}(:\d\d{0,1}){0,1}(\sa.m|\sp.m){0,1}`)
var str = `set alarm at 33:20 p.m`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}