import re
regex = re.compile(r"(\d\d{0,1}){1}(:\d\d{0,1}){0,1}(\sa.m|\sp.m){0,1}")
test_str = "set alarm at 33:20 p.m"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")