re = /(\d\d{0,1}){1}(:\d\d{0,1}){0,1}(\sa.m|\sp.m){0,1}/
str = 'set alarm at 33:20 p.m'
# Print the match result
str.match(re) do |match|
puts match.to_s
end