import Foundation
let pattern = #"(\d\d{0,1}){1}(:\d\d{0,1}){0,1}(\sa.m|\sp.m){0,1}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"set alarm at 33:20 p.m"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}