// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d\d{0,1}){1}(:\d\d{0,1}){0,1}(\sa.m|\sp.m){0,1}").unwrap();
let string = "set alarm at 33:20 p.m";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}