using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!100)\d{6,9}";
string substitution = @"*";
string input = @"123456789012
Don't match: 10012345
Match: 1045677
Don't match:
1004567
Don't match: num=""10034567"" test
Match just the middle number in the line: num=""10048876"" 1200476, 1008888";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}