$re = '/\b(?!100)\d{6,9}/';
$str = '123456789012
Don\'t match: 10012345
Match: 1045677
Don\'t match:
1004567
Don\'t match: num="10034567" test
Match just the middle number in the line: num="10048876" 1200476, 1008888';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;