import Foundation
let pattern = #"\b(?!100)\d{6,9}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
123456789012
Don't match: 10012345
Match: 1045677
Don't match:
1004567
Don't match: num="10034567" test
Match just the middle number in the line: num="10048876" 1200476, 1008888
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)