import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!100)\\d{6,9}";
final String string = "123456789012\n\n"
+ "Don't match: 10012345\n\n"
+ "Match: 1045677\n\n"
+ "Don't match:\n\n"
+ "1004567\n\n"
+ "Don't match: num=\"10034567\" test\n\n"
+ "Match just the middle number in the line: num=\"10048876\" 1200476, 1008888";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}