using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)([0-9]GB|GB)[!@#$%^&*() _,.:]\w+ (?:\w+\s+){1,3}application";
string input = @"Gb:2 existing application While comparing with iPhone and Samsung
application we can easily say that iPhone has some extra application and features.
But most of the application in iPhone are now available in Samsung also.
Please look at the below comparison.Gb,8 with application Apple iPhone
8Gb with extra application and features Apple iPhone 4Gb with extra application
and features Samsung Gb-2s with extra application and features Samsung
2Gb with extra application and features";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}