const regex = new RegExp('(?i)([0-9]GB|GB)[!@#$%^&*() _,.:]\\w+ (?:\\w+\\s+){1,3}application', 'g')
const str = `Gb:2 existing application While comparing with iPhone and Samsung
application we can easily say that iPhone has some extra application and features.
But most of the application in iPhone are now available in Samsung also.
Please look at the below comparison.Gb,8 with application Apple iPhone
8Gb with extra application and features Apple iPhone 4Gb with extra application
and features Samsung Gb-2s with extra application and features Samsung
2Gb with extra application and features`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}