import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)([0-9]GB|GB)[!@#$%^&*() _,.:]\\w+ (?:\\w+\\s+){1,3}application";
final String string = "Gb:2 existing application While comparing with iPhone and Samsung \n"
+ "application we can easily say that iPhone has some extra application and features. \n"
+ "But most of the application in iPhone are now available in Samsung also.\n"
+ "Please look at the below comparison.Gb,8 with application Apple iPhone \n"
+ "8Gb with extra application and features Apple iPhone 4Gb with extra application\n"
+ "and features Samsung Gb-2s with extra application and features Samsung \n"
+ "2Gb with extra application and features";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}