// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([0-9]GB|GB)[!@#$%^&*() _,.:]\w+ (?:\w+\s+){1,3}application").unwrap();
let string = "Gb:2 existing application While comparing with iPhone and Samsung
application we can easily say that iPhone has some extra application and features.
But most of the application in iPhone are now available in Samsung also.
Please look at the below comparison.Gb,8 with application Apple iPhone
8Gb with extra application and features Apple iPhone 4Gb with extra application
and features Samsung Gb-2s with extra application and features Samsung
2Gb with extra application and features";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}