re = /(?i)([0-9]GB|GB)[!@#$%^&*() _,.:]\w+ (?:\w+\s+){1,3}application/
str = 'Gb:2 existing application While comparing with iPhone and Samsung
application we can easily say that iPhone has some extra application and features.
But most of the application in iPhone are now available in Samsung also.
Please look at the below comparison.Gb,8 with application Apple iPhone
8Gb with extra application and features Apple iPhone 4Gb with extra application
and features Samsung Gb-2s with extra application and features Samsung
2Gb with extra application and features'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end