#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^function|[ ;}\n=]function)(|[ ]+[a-zA-Z_0-9]*[ ]*)([(]([^()]|(?3))*[)])[ \n]*([{]([^{}]|(?5))*[}])"
Local $sString = "function(hjsjds(asasa)){kldsklsdjskhd ={ b = function(){ }; } ;ksdjdskdk jksjdsdsdksnn}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)