package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^function|[ ;}\n=]function)(|[ ]+[a-zA-Z_0-9]*[ ]*)([(]([^()]|(?3))*[)])[ \n]*([{]([^{}]|(?5))*[}])`)
var str = `function(hjsjds(asasa)){kldsklsdjskhd ={ b = function(){ }; } ;ksdjdskdk jksjdsdsdksnn}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}