import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^function|[ ;\\}\\n=]function)(|[ ]+[a-zA-Z_0-9]*[ ]*)([(]([^()]|(?3))*[)])[ \\n]*([\\{]([^\\{\\}]|(?5))*[\\}])";
final String string = "function(hjsjds(asasa)){kldsklsdjskhd ={ b = function(){ }; } ;ksdjdskdk jksjdsdsdksnn}\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}