re = /(^function|[ ;}\n=]function)(|[ ]+[a-zA-Z_0-9]*[ ]*)([(]([^()]|(?3))*[)])[ \n]*([{]([^{}]|(?5))*[}])/
str = 'function(hjsjds(asasa)){kldsklsdjskhd ={ b = function(){ }; } ;ksdjdskdk jksjdsdsdksnn}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result