package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^I specified a (?:(valid X estimation request)|(valid X cancel estimation)|(valid X accept estimation)|(valid X refuse estimation)|(valid Y estimation request)) JSON as body$`)
var str = `// Should match :
I specified a valid X estimation request JSON as body
I specified a valid X cancel estimation JSON as body
I specified a valid X accept estimation JSON as body
I specified a valid X refuse estimation JSON as body
I specified a valid Y estimation request JSON as body`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}