use strict;
my $str = '// Should match :
I specified a valid X estimation request JSON as body
I specified a valid X cancel estimation JSON as body
I specified a valid X accept estimation JSON as body
I specified a valid X refuse estimation JSON as body
I specified a valid Y estimation request JSON as body';
my $regex = qr/^I specified a (?:(valid X estimation request)|(valid X cancel estimation)|(valid X accept estimation)|(valid X refuse estimation)|(valid Y estimation request)) JSON as body$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}